Upgrading OPatch to the latest version

Oracle currently ships 12cR1 (12.1.0.2) as the preferred install.

Being the R1 release it needs a lot of patching, and now many patches require OPatch 12.1.0.2, although the OPatch shipped with Grid 12.1.0.2 is in fact OPatch 12.1.0.1.3.

So you need to patch OPatch, before you can apply the patches you need to make 12cR1 work.  Follow?

Okay so do that you need to

Download patch 6880880 from Oracle.  It comes as a simple zip file.

Log in to Linux as root and move to the Grid Infrastructure home.

Rename the current OPatch.

[root@unirac02 ~]# cd $ORACLE_HOME
[root@unirac02 grid]# mv OPatch OPatch.bak

Unzip the file downloaded,  it will create a new OPatch directory

[root@unirac02 grid]# unzip /home/oracle/media/p6880880_122010_Linux-x86-64.zip

Change the permissions of the new directory to your oracle user and default group.

[root@unirac01 grid]# chown -R oracle:oinstall OPatch

Log in as oracle and check it works:

[oracle@unirac01 grid]$ OPatch/opatch version
OPatch Version: 12.2.0.1.8

OPatch succeeded.
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s